hdu 2830 Matrix Swapping II

Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output
Output one line for each test case, indicating the maximum possible goodness.

Sample Input
3 4
1011
1001
0001
3 4
1010
1001
0001

Sample Output
4
2

Note: Huge Input, scanf() is recommended.


求最大完全矩形的基本思想就是以每一行作为底,因为任意列可以调用,我们记录当前行为底的时候以某一个点的高度,然后排序,从大到小的排序,然后扫描到后面每一个点的高度为矩形高度的最大矩形面积就是a[i]*i

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[1005],a[1005];
int main()
{
	int m,n,i,j,ans;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		int ans=0;char t[1005];
		memset(num,0,sizeof(num));
		for(i=1;i<=m;i++)
		{
			scanf("%s",t+1);
			for(j=1;j<=n;j++)
			{
				
				if(t[j]=='1')
				num[j]++;
				else
				num[j]=0;
				a[j]=num[j];
			}
			sort(a+1,a+1+n);
			for(j=n;j>0;j--)
			{
				if(a[j])
				ans=max(ans,a[j]*(n-j+1));
			}
		}
		printf("%d\n",ans);
	}
	return 0;
} 
 




你可能感兴趣的:(hdu 2830 Matrix Swapping II)