POJ 2253 Frogger(最短路--floyd变形)

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 30746   Accepted: 9911

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

刚开始看到以为是求最短路,但是画了一下发现并不是,题意是求一条点1到点2的最短路,
但是这个最短路的最长边必须比没在最短路中的边都要小,然后输出最短路中的最长边,
所以我用floyd算法来做

ac代码:
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 1010
#define INF 0xfffffff
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int x[MAXN];
int y[MAXN];
double pri[MAXN][MAXN];
int main()
{
	int n;
	int i,j,k;
	int cas=0;
	while(scanf("%d",&n)!=EOF,n)
	{
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&x[i],&y[i]);
		}
		for(i=1;i<=n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				double s=sqrt(1.0*((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])));
				pri[i][j]=pri[j][i]=s;
			}
		}
		for(k=1;k<=n;k++)
		{
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					if(pri[i][j]>pri[i][k]&&pri[i][j]>pri[k][j])//从点i到点j直达的边长比通过的两条路都长的话,选择借助另一个节点
					{
						pri[i][j]=pri[j][i]=max(pri[i][k],pri[k][j]);//pri[i][j]中存的不再是最短距离,而是最短路中最大边
					}
				}
			}
		}
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",++cas,pri[1][2]);
	}
	return 0;
}


你可能感兴趣的:(POJ 2253 Frogger(最短路--floyd变形))