Pascal's Travels

类型:
没有
没有 难度     lv.1     lv.2     lv.3     lv.4     lv.5     lv.6     lv.7     lv.8     lv.9     lv.10 搜索 数据结构 动态规划 STL练习 高精度计算 图论 几何 数学 矩阵计算 入门题目 字符串 博弈论 添加

题目描述

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.

Pascal's Travels_第1张图片
Figure 1
Pascal's Travels_第2张图片
Figure 2

输入

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

输出

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

样例输入

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

样例输出

3
0

7

题解:从第一个到最后一个位置的走法只有两个方向,向右或向下。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
__int64 dp[38][38];  
int str[35][35];
char e[35][35];
int main(){
	int n;
	while(cin >> n){
		if(n==-1) break;
		memset(dp,0,sizeof(dp));
		for(int i=0;i<n;i++) scanf("%s",e[i]);
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				str[i][j]=e[i][j]-'0';
			}
		}
		dp[0][0]=1;
		for(int i=0;i<n;i++){
			for(int j=0;j<n;j++){
				if(str[i][j]==0) continue;
				if(i+str[i][j]<n) dp[i+str[i][j]][j]+=dp[i][j];
				if(j+str[i][j]<n) dp[i][j+str[i][j]]+=dp[i][j];
			}
		}
		printf("%I64d\n",dp[n-1][n-1]);
	}
	return 0;
}


你可能感兴趣的:(dp)