Exam
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1029 Accepted Submission(s): 511
Problem Description
As this term is going to end, DRD needs to prepare for his final exams.
DRD has
n exams. They are all hard, but their difficulties are different. DRD will spend at least
ri hours on the
i -th course before its exam starts, or he will fail it. The
i -th course's exam will take place
ei hours later from now, and it will last for
li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.
So he wonder whether he can pass all of his courses.
No two exams will collide.
Input
First line: an positive integer
T≤20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer
n≤105 , and
n lines follow. In each of these lines, there are 3 integers
ri,ei,li , where
0≤ri,ei,li≤109 .
Output
For each test case: output ''Case #x: ans'' (without quotes), where
x is the number of test cases, and
ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).
Sample Input
2
3
3 2 2
5 100 2
7 1000 2
3
3 10 2
5 100 2
7 1000 2
Sample Output
Source
The 2015 ACM-ICPC China Shanghai Metropolitan Programming Contest
Recommend
We have carefully selected several similar problems for you: 5551 5550 5549 5548 5547
无脑排序加判断
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
int t,e,l;
}edge[100000];
bool cmp(node s1,node s2)
{
return s1.e<s2.e;
}
int main()
{
int t;
int Case=1;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d%d%d",&edge[i].t,&edge[i].e,&edge[i].l);
sort(edge,edge+n,cmp);
int sum=0;
int flog=0;
for(int i=0;i<n;i++)
{
sum+=edge[i].t;
if(sum>edge[i].e)
{
flog=1;break;
}
sum+=edge[i].l;
}
printf("Case #%d: ",Case++);
if(flog) printf("NO\n");
else printf("YES\n");
}
return 0;
}