POJ 1258:Agri-Net:典型prim最小生成树(3)

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38661   Accepted: 15592

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

USACO 102
还是非常典型的prim算法,计算最小生成树,该题目比前两个更加明白,简直赤裸裸的prim算法。
将上一个题目的程序核心不变,稍加修改输入输出,AC!
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define maxn 100000000
int n,d[105],a[105][105],use[105];
void init()
{
	int i,j;
	for(i=0;i<n;i++)
		d[i]=use[i]=0;
	for(i=0;i<n;i++)
		for(j=0;j<n;j++)
			scanf("%d",&a[i][j]);
}
void prim()
{
	int i,j;
	int minc,mind;
	use[0]=1;
	d[0]=0;
	for(i=1;i<n;i++)
		d[i]=a[0][i];
	for(j=0;j<n-1;j++)
	{
		minc=maxn;
		for(i=0;i<n;i++)
		{
			if(!use[i]&&minc>d[i])
			{
				minc=d[i];
				mind=i;
			}
		}
		if(minc!=maxn)
		{
			use[mind]=1;
			for(i=0;i<n;i++)
			{
				if(!use[i]&&d[i]>a[mind][i])
					d[i]=a[mind][i];
			}
		}
	}
}
void print()
{
	int i,j;
	int sum=0;
	for(i=0;i<n;i++)
		sum+=d[i];
	printf("%d\n",sum);
}
int main()
{
	int i,j;
	while(scanf("%d",&n)!=EOF&&n)
	{
		init();
		prim();
		print();
	}
	return 0;
}


你可能感兴趣的:(POJ 1258:Agri-Net:典型prim最小生成树(3))