Counting Sheep
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2156 Accepted Submission(s): 1421
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.
Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.
Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
Input
The first line of input contains a single number T, the number of test cases to follow.
Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.
Notes and Constraints
0 < T <= 100
0 < H,W <= 100
Sample Input
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###
Sample Output
Source
IDI Open 2009
#include<stdio.h>
int sum, n, m, dx[4]={-1,1,0,0}, dy[4]={0,0,-1,1};
char map[110][110];
void dfs(int x, int y)
{
map[x][y] = '.';
for(int d = 0; d < 4; d++)
{
int nx=x+dx[d], ny=y+dy[d];
if(nx>=0&&nx<n&&ny>=0&&ny<m&&map[nx][ny]!='.')
{
map[nx][ny] = '.';
dfs(nx,ny);
}
}
}
int main()
{
int T;
scanf("%d", &T);
while(T--)
{
scanf("%d%d", &n, &m);
for(int i = 0; i < n; i++)
scanf("%s", map[i]);
sum = 0;
for(int i = 0; i < n; i++)
{
for(int j = 0; j < m; j++)
{
if(map[i][j] == '#')
{
dfs(i,j);
sum++;
}
}
}
printf("%d\n", sum);
}
}
题意:给出一个迷宫,由‘。’和‘#’组成,若‘#’的上下左右也是‘#’,那么就说这两个属于同一个块,现在问迷宫内有多少个块。
思路:就是基础的搜索题,用深搜去做,都不需要回溯,直接标记就是了。