hdu 1423 Greatest Common Increasing Subsequence (最长上升公共子序列)

Problem Description

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2


题意:最长上升公共子序列

dp[i][j]代表a数组中前i个元素与b数组中前j个元素的最大公共上升子序列

#include <iostream>
#include <memory.h>
#include <algorithm>
#include <string>
#define NUM 1001
using namespace std;
int dp[NUM][NUM];
int a[NUM];
int b[NUM];

int main()
{
    int t;
    cin>>t;
    int n1,n2,Max;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        cin>>n1;
        for(int i=1;i<=n1;i++)
        {
            cin>>a[i];
        }
        cin>>n2;
        for(int j=1;j<=n2;j++)
        {
            cin>>b[j];
        }
        for(int i=1;i<=n1;i++)
        {
            Max=0;
            for(int j=1;j<=n2;j++)
            {
                dp[i][j]=dp[i-1][j];
                if(a[i]>b[j]&&Max<dp[i-1][j])
                    Max=dp[i-1][j];
                if(a[i]==b[j])
                    dp[i][j]=Max+1;
            }
        }
        Max=0;
        for(int i=1;i<=n2;i++)
        {
            if(Max<dp[n1][i])
                Max=dp[n1][i];
        }
        cout<<Max<<endl;
        if(t)
            cout<<endl;
    }
}


你可能感兴趣的:(动态规划,ACM,杭电)