HDU 4763 字符串的前中后三段公共子串

Description

It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input

      
      
      
      
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output

      
      
      
      
0 0 1 1 2
 
前中后三段子串之间可以不存在其他字母

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>

using namespace std;

int n;
char s[1001000];
int main()
{
    while(~scanf("%d",&n))
    {
        while(n--)
        {
            scanf("%s",s);
            int len=strlen(s);
            int len1=len/3;
            int top=len-1;
            int flag=0,Max=0,j,k;
            for(int i=len1-1; i>=0; i--)
            {
                top=len-1;
                flag=0;
                if(s[i]!=s[top])  //减少时间
                    continue;
                if(s[i]==s[top])
                {
                    top=top-i;
                    for( j=0; j<=i; j++)
                    {
                        if(s[j]!=s[top++])
                        {
                            flag=1;
                            break;
                        }
                    }
                }
                if(flag==0)    //必须在上一个判断成立之后才能进行
                {
                    j=0;
                    k=top=i+1;
                    for(; j<=i&&top<len-i-1;)
                    {
                        if(s[j]==s[top])
                        {
                            top++;
                            j++;
                        }
                        else
                        {
                            j=0;
                            k++;
                            top=k;
                        }
                    }
                    if(j==i+1)
                    {
                        Max=i+1;
                        break;
                    }
                }
            }
            printf("%d\n",Max);
        }
    }
}


你可能感兴趣的:(HDU 4763 字符串的前中后三段公共子串)