hdu3951——Coin Game(简单博弈)

Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.
hdu3951——Coin Game(简单博弈)_第1张图片

The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn’t take 1, 3, 4, because 1 and 3 aren’t continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=109,1<=K<=10).

Output
For each case, output the number of case and the winner “first” or “second”.(as shown in the sample output)

Sample Input
2
3 1
3 2

Sample Output
Case 1: first
Case 2: second

如果一次最多取1个,那么只能根据总数的奇偶性来判断。
如果大于一个,那么不管先手怎么取,后手总能取一个对称的,这里的对称是指图案对称,比如奇数的圈,A先取两个,B就在对面取1个,最后总能留小于k个给后手

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define MAXN 10005
using namespace std;
int main()
{
    int t,n,k,cnt=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        if(k>=n)
        {
            printf("Case %d: first\n",cnt++);
            continue;
        }
        if(k==1)
        {
            if(n%2)
                printf("Case %d: first\n",cnt++);
            else
                printf("Case %d: second\n",cnt++);
        }
        else
            printf("Case %d: second\n",cnt++);
    }
    return 0;
}

你可能感兴趣的:(游戏,c,ACM,play)