Truck History
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 21505 |
|
Accepted: 8360 |
Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.
Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)
where the sum goes over all pairs of types in the derivation plan such that t
o is the original type and t
d the type derived from it and d(t
o,t
d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.
Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0
Sample Output
The highest possible quality is 1/3.
题意:
大串的英文题,看着就头疼(心塞,一个字符串是由另一个字符串演变而来,所以要求出两个字符串不同的字母数,而最后结果要求出最少的次数,
这就可以用最小生成树了,两个字符串不同字符数量我用pri[i][j]来表示,然后就是最小生成树了
ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
#define max(a,b) a>b?a:b
#define MAXN 2010
#define INF 0xfffffff
using namespace std;
int pri[MAXN][MAXN];
int v[MAXN];
int dis[MAXN];
int sum,n;
char s[MAXN][10];
void prime()
{
int k,i,j;
int M;
memset(v,0,sizeof(v));
v[1]=1;
sum=0;
for(i=1;i<=n;i++)
{
dis[i]=pri[1][i];
}
for(i=0;i<n;i++)
{
M=INF;
for(j=1;j<=n;j++)
{
if(v[j]==0&&dis[j]<M)
{
M=dis[j];
k=j;
}
}
if(M==INF)
break;
v[k]=1;
sum+=M;
for(j=1;j<=n;j++)
{
if(v[j]==0&&pri[k][j]<dis[j])
dis[j]=pri[k][j];
}
}
}
int main()
{
int i,j,q;
while(scanf("%d",&n),n)
{
for(i=1;i<=n;i++)
scanf("%s",s[i]);
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
int k=0;
for(q=0;q<7;q++)//计算不同字符个数
{
if(s[i][q]!=s[j][q])
k++;
}
pri[i][j]=pri[j][i]=k;
}
}
prime();
printf("The highest possible quality is 1/%d.\n",sum);
}
return 0;
}