BestCoder Round #81 (div.2)A

Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 174    Accepted Submission(s): 107




Problem Description
There is a machine with m(2m30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes.
For any changed bulb,

if it is red now it will be green;

if it is green now it will be blue;

if it is blue now it will be red and the bulb that on the left(if it exists) will change too.

Initally all the bulbs are red. What colour are the bulbs after the button be
pushed n(1n<263) times?
 

Input
There are multiple test cases. The first line of input contains an integer T(1T15) indicating the number of test cases. For each test case:

The only line contains two integers m(2m30) and n(1n<263) .
 

Output
For each test case, output the colour of m bulbs from left to right.
R indicates red. G indicates green. B indicates blue.
 

Sample Input
   
   
   
   
2 3 1 2 3
 

Sample Output
   
   
   
   
RRG GR
 

Source
BestCoder Round #81 (div.2)
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5674  5673  5672  5671  5669

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <algorithm>
#include <set>
#define LL long long
using namespace std;
int A[100];
char s[]="RGB";
int main()
{
    int t;
    LL a,b;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        memset(A,0,sizeof(A));
        int k=0;
        while(b)
        {
            A[++k]=b%3;
            b/=3;
        }
        for(int i=a;i>=1;i--)
            printf("%c",s[A[i]]);
        printf("\n");
    }
    return 0;
}

 

你可能感兴趣的:(BestCoder Round #81 (div.2)A)