CodeForces 628 B. New Skateboard(水~)

Description
给出一个数字串,问这个数字串的子串中能整除4的子串数(子串可以包括前置0)
Input
一个数字串,长度不超过3*10^5
Output
输出该串能整除4的子串数量
Sample Input
124
Sample Output
4
Solution
简单题,一个子串的后两位能整除4那么这个子串就能整除4,所以枚举每相邻两位看是否能整除4即可
Code

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
#define maxn 333333
char s[maxn];
int main()
{
    while(~scanf("%s",s))
    {
        int len=strlen(s);
        ll ans=0;
        for(int i=len-1;i>=0;i--)
        {
            if((s[i]-'0')%4==0)ans++;
            if(i==0)break;
            int temp=((s[i-1]-'0')*10+s[i]-'0')%4;
            if(!temp)ans+=i;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

你可能感兴趣的:(CodeForces 628 B. New Skateboard(水~))