HDU-ACM2117

Just a Numble

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2952    Accepted Submission(s): 1454


Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed
 

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)
 

Output
For each line of input, your program should print a numble on a line,according to the above rules
 

Sample Input
   
   
   
   
4 2 5 7 123 123
 

Sample Output
   
   
   
   
5 0 8

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        while (input.hasNext()){
            int n=input.nextInt();
            int m=input.nextInt();
            int x=1,i;
            int quotient=0,remainder;
            for (i=0;i<m+1;i++){
                quotient=0;
                quotient=x/n;
                remainder=x%n;
                if (quotient==0){
                    x*=10;
                }else {
                    x=remainder*10;
                }
                if (x==0){
                    break;
                }
            }
            if (i<m){
                quotient=0;
            }
            System.out.println(quotient);
        }
    }
}


你可能感兴趣的:(java,算法,编程语言,ACM,杭电)