poj3067之树状数组

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19073   Accepted: 5170

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=1000+10;
int n,m,k;
int c[MAX];

struct Node{
	int x,y;
	bool operator<(const Node &a)const{
		if(x == a.x)return y<a.y;
		return x<a.x;
	}
}s[MAX*MAX];

int lowbit(int x){
	return x&(-x);
}

void Update(int x,int y){
	while(x<=m){
		c[x]+=y;
		x+=lowbit(x);
	}
}

int Query(int x){
	int sum=0;
	while(x>0){
		sum+=c[x];
		x-=lowbit(x);
	}
	return sum;
}

int main(){
	int t,num=0;
	scanf("%d",&t);
	while(t--){
		memset(c,0,sizeof c);
		scanf("%d%d%d",&n,&m,&k);
		for(int i=0;i<k;++i){
			scanf("%d%d",&s[i].x,&s[i].y);
		}
		sort(s,s+k);
		LL sum=0;
		for(int i=0;i<k;++i){
			sum+=i-Query(s[i].y);
			Update(s[i].y,1);
		}
		printf("Test case %d: %lld\n",++num,sum);
	}
	return 0;
}

你可能感兴趣的:(poj3067之树状数组)