POJ 1066 Treasure Hunt (判断线段相交个数)

Treasure Hunt
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6138   Accepted: 2548

Description

Archeologists from the Antiquities and Curios Museum (ACM) have flown to Egypt to examine the great pyramid of Key-Ops. Using state-of-the-art technology they are able to determine that the lower floor of the pyramid is constructed from a series of straightline walls, which intersect to form numerous enclosed chambers. Currently, no doors exist to allow access to any chamber. This state-of-the-art technology has also pinpointed the location of the treasure room. What these dedicated (and greedy) archeologists want to do is blast doors through the walls to get to the treasure room. However, to minimize the damage to the artwork in the intervening chambers (and stay under their government grant for dynamite) they want to blast through the minimum number of doors. For structural integrity purposes, doors should only be blasted at the midpoint of the wall of the room being entered. You are to write a program which determines this minimum number of doors.
An example is shown below:
POJ 1066 Treasure Hunt (判断线段相交个数)_第1张图片

Input

The input will consist of one case. The first line will be an integer n (0 <= n <= 30) specifying number of interior walls, followed by n lines containing integer endpoints of each wall x1 y1 x2 y2 . The 4 enclosing walls of the pyramid have fixed endpoints at (0,0); (0,100); (100,100) and (100,0) and are not included in the list of walls. The interior walls always span from one exterior wall to another exterior wall and are arranged such that no more than two walls intersect at any point. You may assume that no two given walls coincide. After the listing of the interior walls there will be one final line containing the floating point coordinates of the treasure in the treasure room (guaranteed not to lie on a wall).

Output

Print a single line listing the minimum number of doors which need to be created, in the format shown below.

Sample Input

7 
20 0 37 100 
40 0 76 100 
85 0 0 75 
100 90 0 90 
0 71 100 61 
0 14 100 38 
100 47 47 100 
54.5 55.4 

Sample Output

Number of doors = 2 


题意:一个区域,中间有n道墙,给你墙的两个端点和一个珠宝的坐标,你要破墙而入把珠宝拿出来,求最少的破墙数

思路:枚举P点与区域边缘上各点(即墙的两个端点)连接成的线段和其他线段的交点个数,取最小值再加上最开始破
的墙就是解了。。注意没有墙,即n等于0时候的特判

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 60001
#define LL long long
#define INF 0xfffffff
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
struct s
{
	double x1,y1,x2,y2;
}line[MAXN];
struct ss
{
	double x,y;
}p;
double fun(s aa,double xx,double yy)
{
	return (aa.x2-aa.x1)*(yy-aa.y1)-(xx-aa.x1)*(aa.y2-aa.y1);
}
int check(s A,s B)
{
	if(max(A.x1,A.x2)<min(B.x1,B.x2))
	return 0;
	if(max(B.x1,B.x2)<min(A.x1,A.x2))
	return 0;
	if(max(A.y1,A.y2)<min(B.y1,B.y2))
	return 0;
	if(max(B.y1,B.y2)<min(A.y1,A.y2))
	return 0;
	if(fun(B,A.x1,A.y1)*fun(B,A.x2,A.y2)>1e-10)
	return 0;
	if(fun(A,B.x1,B.y1)*fun(A,B.x2,B.y2)>1e-10)
	return 0;
	return 1;
}
int main()
{
	int i,j;
	int n;
    int ans;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		scanf("%lf%lf%lf%lf",&line[i].x1,&line[i].y1,&line[i].x2,&line[i].y2);
		scanf("%lf%lf",&p.x,&p.y);
		if(n==0)
		{
			printf("Number of doors = 1\n");
			continue;
		}
		line[n].x1=p.x;line[n].y1=p.y;
		ans=INF;
		for(i=0;i<n;i++)
		{
			line[n].x2=line[i].x1;line[n].y2=line[i].y1;
			int k=0;
			for(j=0;j<n;j++)
			{
				if(i==j)
				continue;
				if(check(line[n],line[j]))
				k++;
			}
			ans=min(ans,k);
			line[n].x2=line[i].x2;line[n].y2=line[i].y2;
			k=0;
			for(j=0;j<n;j++)
			{
				if(i==j)
				continue;
				if(check(line[n],line[j]))
				k++;
			}
			ans=min(ans,k);
		}
		printf("Number of doors = %d\n",ans+1);
	}
	return 0;
}


你可能感兴趣的:(poj)