hdoj-5605-geometry


Problem Description
There is a point P at coordinate (x,y) .
A line goes through the point, and intersects with the postive part of X,Y axes at point A,B .
Please calculate the minimum possible value of |PA||PB| .
 

Input
the first line contains a positive integer T,means the numbers of the test cases.

the next T lines there are two positive integers X,Y,means the coordinates of P.

T=500 , 0<X,Y10000 .
 

Output
T lines,each line contains a number,means the answer to each test case.



 

Sample Input
   
   
   
   
1 2 1
 

Sample Output
  
  
  
  
4



带入推个数学公式就好了

  #include<cstdio>  
    #include<cstring>  
    #include<cstdlib>  
    #include<iostream>  
    #include<algorithm>  
    #include<cmath>  
    using namespace std;  
    int main()  
    {  
          int x,y;  
          int t;  
          scanf("%d",&t);  
          while(t--)  
          {  
              scanf("%d%d",&x,&y);  
              printf("%d\n",x*y*2);  
          }  
    }  



你可能感兴趣的:(hdoj-5605-geometry)