HDU 2088 Calculate S(n)

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9599 Accepted Submission(s): 3479


Problem Description
Calculate S(n).

S(n)=1 3+2 3 +3 3 +......+n 3 .

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.

Output
For each case, output the last four dights of S(N) in one line.

Sample Input
   
   
   
   
1 2


Sample Output
   
   
   
   
0001 0009
立方公式求和是(n*(n+1)/2)^2

#include<stdio.h>
int main()
{
    long long m;
    while (~scanf("%lld",&m))
    {
        int i,sum=0;
        m=m%10000;
        sum=(m*(m+1)/2)*(m*(m+1)/2)%10000;
        printf("%04lld\n",sum);
    }
    return 0;
}


你可能感兴趣的:(HDU 2088 Calculate S(n))