Hdu 1517 A Multiplication Game

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2717    Accepted Submission(s): 1553


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either

Stan wins.

or

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
   
   
   
   
162 17 34012226
 

Sample Output
   
   
   
   
Stan wins. Ollie wins. Stan wins.
 
#include<cstdio>

int main()
{
    __int64 n;
    __int64 x,flag;
    while(scanf("%I64d",&n)==1)
    {
        x=1;
        flag=0;
        while(x<n)
        {
            x*=9;
            flag++;
            if(x>=n)
                break;
            x*=2;
            flag++;
        }
        if(flag%2)
            printf("Stan wins.\n");
        else
            printf("Ollie wins.\n");
    }
    return 0;
}


你可能感兴趣的:(Hdu 1517 A Multiplication Game)