Pat(Advanced Level)Practice--1041(Be Unique)

Pat1041代码

题目描述:

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

AC代码:
#include<cstdio>
#include<map>
#define MAX 100005

using namespace std;

map<int,int> m;
int Array[MAX];

int main(int argc,char *argv[])
{
	int n,i;
	int index,flag=0;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&index);
		Array[i]=index;
		m[index]++;
	}
	for(i=0;i<n;i++)
	{
		index=Array[i];
		if(m[index]==1)
		{
			flag=1;
			break;
		}
	}
	if(flag==0)
		printf("None\n");
	else
		printf("%d\n",index);
	return 0;
}


你可能感兴趣的:(C++,map,STL,pat,基础题,advance)