Pat(Advanced Level)Practice--1069(The Black Hole of Numbers)

Pat1069代码

题目描述:

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

AC代码:
#include<cstdio>
#include<functional>
#include<algorithm>

using namespace std;

int main(int argc,char *argv[])
{
	int Max[4],Min[4];
	int maxnum,minnum;
	int n;
	int i,j;
	scanf("%d",&n);
	do
	{
		for(i=0;i<4;i++)
		{
			Max[i]=Min[i]=n%10;
			n/=10;
		}
		sort(Max,Max+4,greater<int>());
		sort(Min,Min+4);
		maxnum=minnum=0;
		for(i=0;i<4;i++)
		{
			maxnum=maxnum*10+Max[i];
			minnum=minnum*10+Min[i];
		}
		n=maxnum-minnum;
		printf("%04d - %04d = %04d\n",maxnum,minnum,n);
	}while(n!=0&&n!=6174);

	return 0;
}


你可能感兴趣的:(C++,pat,基础题,advance)