HDOJ 2680 Choose the best route(最短路--dijkstra)

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10365    Accepted Submission(s): 3340


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
   
   
   
   
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
   
   
   
   
1 -1 刚看题写一发,TLE,然后看,可以反向建图,因为终点只有一个,起点可以有好几个,所以可以 寻找从终点到起点的最短路,这样就只需要一次,寻路。 ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 1010
#define INF 0xfffffff
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std;
int pri[MAXN][MAXN];
int v[MAXN];
int dis[MAXN];
int n;
void dijkstra(int x)
{
    int i,j,k;
    memset(v,0,sizeof(v));
    for(i=1;i<=n;i++)
    dis[i]=pri[x][i];
    v[x]=1;
    dis[x]=0;
    int M;
    for(i=0;i<n;i++)
    {
        M=INF;
        for(j=1;j<=n;j++)
        {
            if(v[j]==0&&dis[j]<M)
            {
                M=dis[j];
                k=j;
            }
        }
        if(M==INF)
        break;
        v[k]=1;
        for(j=1;j<=n;j++)
        {
            if(v[j]==0)
            dis[j]=min(dis[j],dis[k]+pri[k][j]);
        }
    }
}
int main()
{
    int i,j,a,b,c,d,q,mi,m;
    while(scanf("%d%d%d",&n,&m,&c)!=EOF)
    {
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++)
        pri[i][j]=INF;
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&d);
            if(pri[b][a]>d)//反向建图
            {
                pri[b][a]=d;
            }
        }
		dijkstra(c);
        scanf("%d",&q);
        mi=INF;
        for(i=0;i<q;i++)
        {
            scanf("%d",&a);
            if(dis[a]!=INF)
            mi=min(mi,dis[a]);
        }
        if(mi==INF)
        printf("-1\n");
        else
        printf("%d\n",mi);
    }
    return 0;
}


你可能感兴趣的:(HDOJ 2680 Choose the best route(最短路--dijkstra))