Wolf and Rabbit (HDU 1222)

  这题怎么说呢,,我好失望,因为 HDU 2104 《hide handkerchief》这题跟本题其实是一样的,我以前做过,可现在又不会了%>_<%

 

                    Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1727    Accepted Submission(s): 998
 
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.

Wolf and Rabbit (HDU 1222)_第1张图片

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output

            For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO
YES

程序如下:

//仔细想一下,或模拟一下
//如果有公约数,就会有重复的,即不能遍历完,就输出YES
#include<stdio.h>
int main()
{
    int n,m,t,temp;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        while(m!=0&&m!=1)
        {
            temp=m;
            m=n%m;
            n=temp;
        }
        if(m) puts("NO");
        else  puts("YES");
    }
    return 0;
}


 

你可能感兴趣的:(Math,gcd)