POJ 3624:Charm Bracelet【01背包】

 Charm Bracelet
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 3624

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

AC-code:
 
   
#include<cstdio>
#include<cstring>
#define max(a,b) a>b?a:b
int main()
{
	int m,n,i,j,c[20000],w[4000],p[4000];
	scanf("%d%d",&n,&m);
	for(i=0;i<n;i++)
		scanf("%d%d",&w[i],&p[i]);
	memset(c,0,sizeof(c));
	for(i=0;i<n;i++)
		for(j=m;j>=w[i];j--)
			c[j]=max(c[j],c[j-w[i]]+p[i]);
	printf("%d\n",c[m]);
	return 0;
}


你可能感兴趣的:(poj,背包)