WHU 1604 - Play Apple【博弈】

Problem 1604 - Play Apple
Time Limit: 1000MS    Memory Limit: 65536KB   
Total Submit: 457   Accepted: 182   Special Judge: No
Description

There are N apples. Two people take turns to either: 
1. Divide the apple into two piles with different numbers.
2. The other people selects a pile of apples as the beginning of the next turn.
If someone can not meet the requirements, he is lost. Will the first one win the game if both use the best strategy?

Input
There are multiple test cases.
The first line of each case contains a integer N. ( 1 <= N <= 1000000000 )
Output
If the first person will win, output “Yes”. Otherwise, output “No”.
Sample Input
2
3
4
Sample Output
No
Yes
No
AC-code:
#include<cstdio>
int main()
{
	long long n;
	while(~scanf("%lld",&n))
	{
		if(n%3==1||n==2)
			printf("No\n");
		else
			printf("Yes\n");
	}
	return 0;
 } 


你可能感兴趣的:(WHU 1604 - Play Apple【博弈】)