HDU 1728 逃离迷宫

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1728

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
   
   
   
   
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
   
   
   
   
no yes
 

解题思路:

BFS模板题

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
using namespace std;
struct point
{
    int x;
    int y;
    int step;
}p, pp;
#define  N 150
int m, n;
int  k, x1, x2, y_1, y2;
int sign[N][N];
int d[4][2] = { { 1, 0 }, { -1, 0 }, { 0, 1 }, { 0, -1 } };
char map[N][N];
queue<point> all;
bool ok(int x, int y)
{
    if (x >= 1 && x <= m&&y >= 1 && y <= n&&map[x][y] == '.')
        return true;
    return false;
}
bool bfs()
{
    if (x1 == x2&&y_1 == y2)
        return true;
    sign[x1][y_1] = 1;
    p.x = x1, p.y = y_1, p.step = -1;
    all.push(p);
    while (!all.empty())
    {
        p = all.front();
        all.pop();
        for (int i = 0; i < 4; i++){
            int xx = p.x + d[i][0];
            int yy = p.y + d[i][1];
            while (ok(xx, yy))
            {
                if (!sign[xx][yy]){
                    sign[xx][yy] = 1;
                    pp.x = xx, pp.y = yy, pp.step = p.step + 1;   
                    all.push(pp);
                    if (pp.step <= k&&pp.x == x2&&pp.y == y2)
                        return true;
                }
                xx += d[i][0];
                yy += d[i][1];
            }
        }
    }
    return false;
}
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d", &m, &n);
        memset(sign, 0, sizeof(sign));
        while (!all.empty()) all.pop();  // 队的初始化
        for (int i = 1; i <= m; i++)
        for (int j = 1; j <= n; j++)
            scanf(" %c", &map[i][j]);
        scanf("%d%d%d%d%d", &k, &y_1, &x1, &y2, &x2); //注意输入数据的顺序,表示没看清题别这里坑了..
        if (bfs())
            puts("yes");
        else
            puts("no");
    }
    return 0;
}


你可能感兴趣的:(C++,ACM,bfs)