Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8891 Accepted Submission(s): 1863
Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.
Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
Input
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.
Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.
Sample Input
Sample Output
Case 1.
2 2 3 1 5 1
Case 2.
2 2 3 1
提交时出现out put limit Exceeded错误,原来是a的范围搞错了a必须要大于1,而不是不等于-1.
#include<stdio.h>
int main()
{
int i,j,k,a,b,c,s=0;
while(scanf("%d",&a)&&a>1)
{
if(s)
{
printf("\n");
}
printf("Case %d.\n",++s);
b=2;j=1;k=0;c=a;
for(i=2;i<=c;i++)
{
if(a%i==0)
{
a=a/i;
j=0;k++;i--;
}
else if(k!=0)
{
printf("%d %d ",i,k);
k=0;
}
}
printf("\n");
}
return 0;
}