HDU 1009 FatMouse' Trade (贪心)

D - FatMouse' Trade
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 
 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 
 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 
 

Sample Input

      
      
      
      
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output

      
      
      
      
13.333 31.500

 

这道题目大家只要认清一个东西就可以了a%,说的是,当J[i]与F[i]明显不足,a%便是J[i] / F[i].

如此用贪心就可。


#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN = 1000 + 5;
int M, N;
struct JF{
    double J, F, R;
    bool operator < (const JF &a) const{
        return R > a.R;
    }
}jf[MAXN];
int main(){
    while(~scanf("%d%d", &M, &N), M != -1 && N != -1){
        for(int i = 0;i < N;i ++){
            scanf("%lf%lf", &jf[i].J, &jf[i].F);
            jf[i].R = jf[i].J / jf[i].F;
        }
        sort(jf, jf + N);
        double ans = 0;
        for(int i = 0;i < N;i ++){
            if(M >= jf[i].F){
                ans += jf[i].J;
                M-= jf[i].F;
            }
            else{
                ans += (jf[i].J / jf[i].F) * M;
                break;
            }
        }
        printf("%.3lf\n", ans);
    }
    return 0;
}



你可能感兴趣的:(HDU 1009 FatMouse' Trade (贪心))