HDU4763 Theme Section KMP

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2171    Accepted Submission(s): 1016


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
   
   
   
   
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
   
   
   
   
0 0 1 1 2
 



题意:在一个字符串中间找一个最大的子串,使得它和串开头和结尾都相同即 EAEBE形式。

KMP先求出next数组,找出前缀最大匹配长度。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <cmath>
#include <algorithm>

using namespace std;

char s[1000009];
int nt[1000009];
int vis[1000009];

int fff;

void get_next(int len)
{
    int i=0,j=-1;
    nt[0]=-1;

    while(i<len)
    {
        if(j==-1 || s[i]==s[j])
            nt[++i]=++j;
        else
            j=nt[j];
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",s);
        int len=strlen(s);
        int ans=0;

         //kmp_pre(s,len);
         get_next(len);
//         for(int i=0;i<=len;i++)
//            cout<<nt[i]<<" ";
//
//         puts("");

        memset(vis,0,sizeof vis);
        int tmp=len;
        while(tmp>0)
        {
            if(len>=tmp*2) vis[tmp]=1;
            tmp=nt[tmp];
        }

        for(int i=len-1;i>1;i--)
        {
            tmp=i;
            while(tmp>0)
            {
                if(vis[tmp] && i>=tmp*2 && i+tmp<=len)
                {
                    ans=max(ans,tmp);
                    break;
                }
                tmp=nt[tmp];
            }
        }

        printf("%d\n",ans);
    }
    return 0;
}

/*

abcdabcaabcdcabcabcd


*/








你可能感兴趣的:(HDU4763 Theme Section KMP)