Score

Score
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  UVA 1585
Appoint description:  System Crawler  (2016-04-15)

Description

There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's. 

Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3". 

You are to write a program calculating the scores of test results. 

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ` O' and ` X' and the length of the string is more than 0 and less than 80. There is no spaces between ` O' and ` X'. 

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case. 

The following shows sample input and output for five test cases. 

Sample Input 

5 
OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX

Sample Output 

10 
9 
7 
55 
30

本题的思路是,定义一个二层循环,第一层循环从左往右找,一旦找到字符”O“,就进入第二层循环,第二层循环依然从左往右搜索,直到遇到“X”或者到了最右边的边界为止。然后把j赋值给i,返回第一层循环。
</pre><pre code_snippet_id="1654856" snippet_file_name="blog_20160420_1_3933707" name="code" class="cpp">#include <string>
#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    int T;
    cin >> T;//变量T表示T组数据
    string s;//保存字符串
    while(T--) {
        cin >> s;
        int sum = 0; //保存结果
        for (int i = 0; i < s.length(); i++) {
            if (s[i] != 'O') continue; //如果字符不为'O',直接跳到下次循环。
            int tempSum = 0;
            for (int j = i; j < s.length(); j++) {
                if (s[j] == 'O') {
                    tempSum++;
                    sum = sum + tempSum;
                    i = j;
                }else {
                    i = j;
                    break;
                }
            }
        }
        cout << sum << endl;
    }
    return 0;
}

你可能感兴趣的:(String,字符串处理)