HDOJ 5012 Dice


BFS爆搜

Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 284    Accepted Submission(s): 166


Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a 1.a 2,a 3,a 4,a 5,a 6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b 1.b 2,b 3,b 4,b 5,b 6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while a i ≠ a j and b i ≠ b j for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, a i ≠ b i). Ddy wants to make the two dices look the same from all directions(which means for all i, a i = b i) only by the following four rotation operations.(Please read the picture for more information)

HDOJ 5012 Dice_第1张图片
Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line consists of six integers a 1,a 2,a 3,a 4,a 5,a 6, representing the numbers on dice A. 

The second line consists of six integers b 1,b 2,b 3,b 4,b 5,b 6, representing the numbers on dice B.
 

Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 

Sample Input
   
   
   
   
1 2 3 4 5 6 1 2 3 4 5 6 1 2 3 4 5 6 1 2 5 6 4 3 1 2 3 4 5 6 1 4 2 5 3 6
 

Sample Output
   
   
   
   
0 3 -1
 

Source
2014 ACM/ICPC Asia Regional Xi'an Online
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <set>
#include <queue>

using namespace std;

struct DICE
{
	int face[6];
}A,B;

bool check(DICE a,DICE b)
{
	for(int i=0;i<6;i++)
		if(a.face[i]!=b.face[i]) return false;
	return true;
}

bool checkIMP(DICE x,DICE y)
{
	int a[6],b[6];
	for(int i=0;i<6;i++)
	{
		a[i]=x.face[i];
		b[i]=y.face[i];
	}
	sort(a,a+6);
	sort(b,b+6);
	for(int i=0;i<6;i++)
	{
		if(a[i]!=b[i]) return false;
	}
	return true;
}

void init(DICE& x)
{
	int a[6];
	for(int i=0;i<6;i++)
		a[i]=x.face[i];
	sort(a,a+6);
	for(int i=0;i<6;i++)
	{
		x.face[i]=lower_bound(a,a+6,x.face[i])-a+1;
	}
}

void showit(DICE x)
{
	for(int i=0;i<6;i++)
		cout<<x.face[i]<<",";
	cout<<endl;
}

int hash(DICE x)
{
	int ret=0;
	for(int i=0;i<6;i++)
		ret=ret*10+x.face[i];
	return ret;
}

void rhash(int h,DICE& x)
{
	for(int i=5;i>=0;i--)
	{
		x.face[i]=h%10;
		h/=10;
	}
}

void LEFT(DICE& X)
{
	int a[6];
	for(int i=0;i<6;i++)
		a[i]=X.face[i];
	X.face[0]=a[3];
	X.face[1]=a[2];
	X.face[2]=a[0];
	X.face[3]=a[1];
}

void RIGHT(DICE& X)
{
	int a[6];
	for(int i=0;i<6;i++)
		a[i]=X.face[i];
	X.face[0]=a[2];
	X.face[1]=a[3];
	X.face[3]=a[0];
	X.face[2]=a[1];
}

void UP(DICE& X)
{
	int a[6];
	for(int i=0;i<6;i++)
		a[i]=X.face[i];
	X.face[0]=a[5];
	X.face[1]=a[4];
	X.face[4]=a[0];
	X.face[5]=a[1];
}

void DOWN(DICE& X)
{	
	int a[6];
	for(int i=0;i<6;i++)
		a[i]=X.face[i];
	X.face[0]=a[4];
	X.face[1]=a[5];
	X.face[4]=a[1];
	X.face[5]=a[0];
}

bool st[1000001];

void bfs()
{
	queue<int> q,qt; 
	memset(st,0,sizeof(st));
	q.push(hash(A)); 
	st[hash(A)]=0;
	qt.push(0);
	bool flag=false;
	while(!q.empty())
	{
		int time=qt.front(); qt.pop();
		int zhi=q.front(); q.pop();
		
		DICE X,Y;int ha;
		rhash(zhi,X); Y=X;
		if(check(Y,B)==true)
		{
			flag=true;
			printf("%d\n",time);
			return ;
		}
		///LEFT
		LEFT(X);
		ha=hash(X);
		if(st[ha]==false)
		{
			st[ha]=true;
			q.push(ha);
			qt.push(time+1);
		}

		///Right
		X=Y;
		RIGHT(X);
		ha=hash(X);
		if(st[ha]==false)
		{
			st[ha]=true;
			q.push(ha);
			qt.push(time+1);
		}

		///UP
		X=Y;
		UP(X);
		ha=hash(X);
		if(st[ha]==false)
		{
			st[ha]=true;
			q.push(ha);
			qt.push(time+1);
		}

		///DOWN
		X=Y;
		DOWN(X);
		ha=hash(X);
		if(st[ha]==false)
		{
			st[ha]=true;
			q.push(ha);
			qt.push(time+1);
		}
	}
	if(flag==false) puts("-1");
}
	

int main()
{
	int x;
	while(scanf("%d",&x)!=EOF)
	{
		A.face[0]=x;
		for(int i=1;i<6;i++) scanf("%d",&A.face[i]);
		for(int i=0;i<6;i++) scanf("%d",&B.face[i]);
		
		if(checkIMP(A,B)==false)	
		{
			puts("-1"); continue;
		}
		init(A); init(B);
		if(check(A,B)==true)
		{
			puts("0"); continue;
		}
		bfs();
	}
	return 0;
}



你可能感兴趣的:(HDOJ 5012 Dice)