POJ 2398 Toy Storage (判断点与直线关系+排序二分计数)

Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4851   Accepted: 2878

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1


题意:和上一个玩具差不多,只不过这个是让求格子内玩具数量为x的有多少个

思路:因为刚给挡板坐标是随机的,所以要排序,后面的用sum数组遍历一下ans就行了

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#define MAXN 60001
#define LL long long
#define INF 0xfffffff
#define fab(x) (x)>0?(x):(-x)
#define mem(x) memset(x,0,sizeof(x))
#define PI acos(-1)
using namespace std;
struct s
{
	int a,b,c,d;
}line[MAXN];
int ans[MAXN];
int sum[MAXN];
int n,m;
bool cmp(s aa,s bb)
{
	return aa.a<bb.a;
}
int check(int x,int y,int i)
{
	double ans=(line[i].b-line[i].d)*x+(line[i].c-line[i].a)*y+(line[i].a*line[i].d-line[i].c*line[i].b);
    if(ans<0)
    return 1;
    return 0;
}
void solve(int x,int y)
{
	int low=0;
	int high=n-1;
	int mid;
	while(low<=high)
	{
		mid=(low+high)/2;
		if(check(x,y,mid)==0)
		low=mid+1;
		else
		high=mid-1;
	}
	ans[low]++;
}
int main()
{
	int t,i,x1,y1,x2,y2,aa,bb;
	while(scanf("%d",&n)!=EOF,n)
	{
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&aa,&bb);
			line[i].a=aa;
			line[i].b=y1;
			line[i].c=bb;
			line[i].d=y2;
		}
		sort(line,line+n,cmp);
		mem(ans);
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&aa,&bb);
			solve(aa,bb);
		}
		mem(sum);
		for(i=0;i<=n;i++)
		{
			sum[ans[i]]++;
		}
		printf("Box\n");
		for(i=1;i<=m;i++)
		{
			if(sum[i])
			printf("%d: %d\n",i,sum[i]);
		}
		//printf("\n");
	}
	return 0;
}


 

你可能感兴趣的:(POJ 2398 Toy Storage (判断点与直线关系+排序二分计数))