Parencodings
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 18885 |
|
Accepted: 11380 |
Description
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
Sample Output
1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
Source
Tehran 2001
找一下左括号和右括号数量之间的规律,很容易AC。
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int t,n,a[25],b[25],c[25];
void input()
{
int i,j;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
if(i==0)
b[i]=a[i]-1;
else
b[i]=a[i]-a[i-1]-1;
}
}
int priot(int x)
{
int i,j;
for(i=x;i>=0;i--)
{
if(b[i]>0)
break;
}
if(i>=0)
return i;
else
return 0;
}
void chuli()
{
int i,j;
for(i=0;i<n;i++)
{
if(b[i]>=0)
c[i]=1;
else
{
j=priot(i);
b[j]--;
c[i]=i-j+1;
b[i]=0;
}
}
}
void output()
{
int i;
for(i=0;i<n;i++)
{
if(i==0)
printf("%d",c[i]);
else
printf(" %d",c[i]);
}
printf("\n");
}
int main()
{
int i,j;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
input();
chuli();
output();
}
}
return 0;
}