POJ 1001

求高精度幂
Time Limit: 500MS   Memory Limit: 10000K
Total Submissions: 120367   Accepted: 29378

Description

对数值很大、精度很高的数进行高精度计算是一类十分常见的问题。比如,对国债进行计算就是属于这类问题。 

现在要你解决的问题是:对一个实数R( 0.0 < R < 99.999 ),要求写程序精确计算 R 的 n 次方(R n),其中n 是整数并且 0 < n <= 25。

Input

T输入包括多组 R 和 n。 R 的值占第 1 到第 6 列,n 的值占第 8 和第 9 列。

Output

对于每组输入,要求输出一行,该行包含精确的 R 的 n 次方。输出需要去掉前导的 0 后不要的 0 。如果输出是整数,不要输出小数点。

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Source

East Central North America 1988

Translator

北京大学程序设计实习,Xie Di

第一次用JAVA A题,感觉还不错。和C++相比JAVA的时间和内存开销的确很大,不过写起来很方便大笑
/*
 * To change this template, choose Tools | Templates
 * and open the template in the editor.
 */
import java.util.Scanner;
import java.math.BigDecimal;

/**
 *
 * @author XM_zhou
 */
public class Main {
    public static void main(String[] args)
    {
        Scanner in = new Scanner (System.in);
        while(in.hasNext())
        {       
                Double r = in.nextDouble();
                Integer n = in.nextInt();
                BigDecimal re = new BigDecimal(r.toString());
                String res = re.pow(n).stripTrailingZeros().toPlainString();
                if(res.startsWith("0"))
                {
                    res = res.substring(1 , res.length());
                }
                System.out.println(res);                         
        }
      
    }
}   
去后导0的用地BigDecimal的stripTrailingZeros,然后使用toPlainString防止高精度数表示成科学计数法(意思就是转换成朴素的字符串)
substring
public String substring(int beginIndex)
返回一个新的 字符串 ,它是此字符串的一个子字符串。该子 字符串 始于指定索引处的字符,一直到此字符串末尾。


你可能感兴趣的:(java,ACM,高精度)