HDU 5210 DELETE

题目链接:delete


题面:

Delete

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 636    Accepted Submission(s): 326


Problem Description
WLD likes playing with numbers. One day he is playing with  N  integers. He wants to delete  K  integers from them. He likes diversity, so he wants to keep the kinds of different integers as many as possible after the deletion. But he is busy pushing, can you help him?
 

Input
There are Multiple Cases. (At MOST  100 )

For each case:

The first line contains one integer  N(0<N100) .

The second line contains  N  integers  a1,a2,...,aN(1aiN) , denoting the integers WLD plays with.

The third line contains one integer  K(0K<N) .
 

Output
For each case:

Print one integer. It denotes the maximum of different numbers remain after the deletion.
 

Sample Input
   
   
   
   
4 1 3 1 2 1
 

Sample Output
   
   
   
   
3
Hint
if WLD deletes a 3, the numbers remain is [1,1,2],he'll get 2 different numbers. if WLD deletes a 2, the numbers remain is [1,1,3],he'll get 2 different numbers. if WLD deletes a 1, the numbers remain is [1,2,3],he'll get 3 different numbers.
 

Source
BestCoder Round #39 ($)
 


解题:

利用set计数即可。


代码:

#include <iostream>
#include <cmath> 
#include <set>
using namespace std;
int main()
{
	int n,k,tmp,ans;
	while(scanf("%d",&n)!=EOF)
	{
		set <int> store;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&tmp);
			store.insert(tmp);
		}
		scanf("%d",&k);
		if(n==store.size())
		{
			ans=n-k;//刚好,就直接减 
		}
		else
		{
			tmp=n-store.size();//可以不减少的前提下,提供的最大数量 
			if(tmp>=k)//够减,,数量不变 
			ans=store.size();
			else      //不够减,减去多余的后,再减种类数 
			ans=store.size()-(k-tmp);
		}
		printf("%d\n",ans);
	}
	return 0;
}


你可能感兴趣的:(入门,set,HDU,最水题)