Beads题解

题目描述

Zxl有一次决定制造一条项链,她以非常便宜的价格买了一长条鲜艳的珊瑚珠子,她现在也有一个机器,能把这条珠子切成很多块(子串),每块有k(k>0)个珠子,如果这条珠子的长度不是k的倍数,最后一块小于k的就不要拉(nc真浪费),保证珠子的长度为正整数。

Zxl喜欢多样的项链,为她应该怎样选择数字k来尽可能得到更多的不同的子串感到好奇,子串都是可以反转的,换句话说,子串(1,2,3)和 (3,2,1)是一样的。

写一个程序,为Zxl决定最适合的k从而获得最多不同的子串。

例如:

这一串珠子是: (1,1,1,2,2,2,3,3,3,1,2,3,3,1,2,2,1,3,3,2,1)

k=1的时候,我们得到3个不同的子串: (1),(2),(3)

k=2的时候,我们得到6个不同的子串: (1,1),(1,2),(2,2),(3,3),(3,1),(2,3) k=3的时候,我们得到5个不同的子串:

(1,1,1),(2,2,2),(3,3,3),(1,2,3),(3,1,2)

k=4的时候,我们得到5个不同的子串:

(1,1,1,2),(2,2,3,3),(3,1,2,3),(3,1,2,2),(1,3,3,2)

输入

共有两行,第一行一个整数n代表珠子的长度,第二行是由空格分开的颜色ai(1<=ai<=n,n<=200005)。

输出

也有两行 第一行两个整数,第一个整数代表能获得的最大不同的子串个数,第二个整数代表能获得最大值的k的个数, 第二行输出所有的k(中间有空格)。

样例输入

21
1 1 1 2 2 2 3 3 3 1 2 3 3 1 2 2 1 3 3 2 1

样例输出

6 1
2

想法

  • 如果我们枚举k的话 计算次数为n+n/2+n/3+n/4……..复杂度为O(nlogn)
  • 剩下的部分hash处理就好了

算法

  • 见代码

代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#define MAXN 200011
#define seed 49999
using namespace std;
typedef unsigned long long ui;
int n,a[MAXN],ans;
ui lhash[MAXN],rhash[MAXN],bs[MAXN],st[MAXN],h,q[MAXN];
inline int judge(int x)
{
    int l=1,r,l2=0;
    while((r=l+x)<=n+1)
    {
        ui hash1=lhash[r-1]-lhash[l-1]*bs[x];
        ui hash2=rhash[l]-rhash[r]*bs[x];
        q[++l2]=min(hash1,hash2);
        l=r;
    }
    sort(q+1,q+1+l2);
    l2=unique(q+1,q+1+l2)-q-1;
    return l2;
}
int main()
{
    scanf("%d",&n);
    bs[0]=1;
    for (int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        lhash[i]=lhash[i-1]*seed+a[i];
        bs[i]=bs[i-1]*seed;
    }
    for (int i=n;i>=1;i--)
        rhash[i]=rhash[i+1]*seed+a[i];
    for (int i=1;i<=n;i++)
    {
        int temp=judge(i);
        if(temp>ans)ans=temp,st[h=1]=i;
        else if(ans==temp)st[++h]=i;
    }
    cout<<ans<<" "<<h<<endl;
    for (int i=1;i<h;i++)cout<<st[i]<<" ";
    cout<<st[h];
    return 0;
}

你可能感兴趣的:(Beads题解)