UVA - 10305 Ordering Tasks (拓扑排序)

Problem F

Ordering Tasks

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

 

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3


题意:

给你节点数n,和边数r,要求你输出其拓扑排序。

拓扑排序:由某个集合上的一个偏序得到该集合上的一个全序,这个操作称之为拓扑排序。

这题是刘汝佳书上介绍拓扑排序的题目,直接套用模板。


注意这里用到了一个c数组,c[u] = 0表示从来没有访问过(从来没有调用过dfs(u))。

c[u] = 1表示已经访问过,并且还递归访问它的子孙(即dfs(u)曾被调用过,并且已返回)。

c[u] = -1表示正在访问(即递归调用dfs(u)正在帧栈中,尚未返回)。


#include <stdio.h>
#include <string.h>
const int N = 110;
int c[N];
int topo[N],t;
int G[N][N];
int n,r;
bool dfs(int u) {
	c[u] = -1; // 访问标志
	for(int v = 1; v <= n; v++) {
		if(G[u][v]) {
			if(c[v] < 0) {
				return false; //存在有向环
			}
			else if( !c[v] && !dfs(v)) {
				return false;
			}
		}
	}
	c[u] = 1;
	topo[--t] = u;
	return true;
}
bool toposort() {
	t = n;
	memset(c,0,sizeof(c));
	for(int u = 1; u <= n; u++) {
		if(!c[u]) {
			if( !dfs(u)) {
				return false;
			}
		}
	}
	return true;
}
int main() {
	int u,v;
	while( scanf("%d%d",&n,&r) != EOF && ( n || r)) {
		memset(G,0,sizeof(G));
		for(int i = 1; i <= r; i++) {
			scanf("%d%d",&u,&v);
			G[u][v]++;
		}
		toposort();
		for(int i = 0; i < n; i++) {
			printf("%d",topo[i]);
			if( i != n-1) {
				printf(" ");
			}
		}
		printf("\n");
	}
	return 0;
}


你可能感兴趣的:(uva,Tasks,Ordering)