树状数组
题意:有两排城市,这两排之间有一些城市之间有连接的道路,给出所有道路,问有多少道路是相交的。
分析:求逆序数
我们先把所有的道路按照a升序,a相同时b升序的方法排列!
Japan
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 15697 |
|
Accepted: 4216 |
Description
Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.
Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1
Sample Output
Test case 1: 5
Source
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=4000000;
int n,m,k,t;
__int64 c[2002];
struct node
{
int a,b;
}p[maxn];
int cmp(node A,node B)
{
if(A.a!=B.a)return A.a<B.a;
return A.b<=B.b;
}
int lowbit(int i)
{
return i&(-i);
}
void add(int i,int d)
{
while(i<=m)
{
c[i]+=d;
i+=lowbit(i);
}
}
__int64 sum(int i)
{
__int64 ret=0;
while(i)
{
ret+=c[i];
i-=lowbit(i);
}
return ret;
}
int main()
{
int i,j,cas=1;
__int64 ans;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&k);
for(i=0;i<=m;i++)c[i]=0;
for(i=1;i<=k;i++)
{
scanf("%d%d",&p[i].a,&p[i].b);
}
sort(p+1,p+k+1,cmp);
for(ans=0,i=1;i<=k;i++)
{
ans+=i-sum(p[i].b)-1;
add(p[i].b,1);
}
printf("Test case %d: %I64d\n",cas++,ans);
}
return 0;
}
/*
3
3 4 4
1 4
2 3
3 2
3 1
3 4 4
1 4
2 3
3 2
3 1
*/