南邮 OJ 1544 Slash

Slash

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 39            测试通过 : 19 

比赛描述

The American English slash (/) is a punctuation mark. In the early modern period, in the Fraktur script, which was widespread through Europe in the Middle Ages, one slash(/) represented a comma, while two slashes (//) represented a dash.
With the wide use of computers, slash appeared far more than at any previous time in history. On Unix-like systems and in URLs, the slash is to separate directory and file components of a path:
/home/whuacm/chaeyeon/Sherlockpp.jpg
http://acm.whu.edu.cn/
But in Windows systems, it uses (\) to separate directory and file components of a path:
C:\Users\v-yungao\Music\Shake
That really confuses me. Could you help me to judge if the string I wrote is right. 
Please notice that I would only make a mistake by changing (\) to (/) or (/) to (\). All the strings were constituted by a-z, A-Z, 0-9, (.) , (\) and (/), no other characters would appear in the strings.
A string of URL always begins with “[a-zA-Z]+://” (Notice (/) maybe changed to (\) ), in which “[a-zA-Z]+” represents any non-empty string of letters.
Windows path begins with “[a-zA-Z]:\” (Notice (\) maybe changed to (/)), in which “[a-zA-Z]” means an English letter. (e.g. “C:\\windows” is a URL not a Windows path)
The path of Unix-like system begins with (/) or (\).
I’ll give you some strings, can you tell me which type those strings belong to and those correct forms.



输入

The first line consists of an integer T, indicating the number of strings.
The next T lines, each line consists of a single non-empty string. All of those are really data from our daily life. 

输出

For each string:
If it belongs to a path in Unix-like systems, output “It’s a path in Unix-like systems!” in a new line and the correct string in the next line.
If it belongs to a path in Windows system, output “It’s a path in Windows system!” in a new line and the correct string in the next line.
If it’s a URL, output “It’s a URL!” in a new line and the correct string in the next line.
The kind of each input string can be uniquely determined. 

Constrains
0 < T <= 20
The length of each string will not be longer than 50.

样例输入

4
http://acm.whu.edu.cn/felioj
http:/\acm.whu.edu.cn/11111011001/
\home\whuacm\Slash\yama
Z:\movie/chaeyeon

样例输出

It's a URL!
http://acm.whu.edu.cn/felioj
It's a URL!
http://acm.whu.edu.cn/11111011001/
It's a path in Unix-like systems!
/home/whuacm/Slash/yama
It's a path in Windows system!
Z:\movie\chaeyeon

提示

undefined

题目来源

Asia Wuhan Regional 2009




#include<stdio.h>
#include<string>
int main(){
	int t,len,i;
	char c[51];
	scanf("%d",&t);
	getchar();
	while(t--){
		scanf("%s",c);
		len = (int)strlen(c);
		for(i=0; i<len; i++){
			if('/'==c[i]){
				c[i] = '\\';
			}
		}
		for(i=1; i+2<len; i++){
			if(isalpha(c[i-1]) && ':' == c[i] && '\\'==c[i+1] && '\\'==c[i+2]){
				break;
			}
		}
		if(i+2<len){
			for(i=0; i<len; i++){
				if('\\'==c[i]){
					c[i] = '/';
				}
			}
			printf("It's a URL!\n%s\n",c);
			continue;
		}
		if(isalpha(c[0]) && ':' == c[1] && '\\'==c[2]){			//WA1
			printf("It's a path in Windows system!\n%s\n",c);
			continue;
		}
		if('\\'==c[0]){
			for(i=0; i<len; i++){
				if('\\'==c[i]){
					c[i] = '/';
				}
			}
			printf("It's a path in Unix-like systems!\n%s\n",c);
			continue;
		}
	}
}



你可能感兴趣的:(ACM,南邮OJ,slash)