Nim or not Nim?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 713 Accepted Submission(s): 337
Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.
Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.
Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
Sample Output
Alice
Bob
数据太大,先打表找到归律 !
/*#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define M 1000600
#define N 10006
int pri[M],re[N];
#define mem(a,b) memset(a,b,sizeof(a))
int mex(int p){
if(re[p]!=-1)return re[p];
int mexx[N]={0};
int ans=0,p2=p/2;
for(int i=p-1;i>=0;i--){
mexx[mex(i)]=1;
}
for(int i=1;i<=p2;i++){
ans=0;
ans^=mex(i);
ans^=mex(p-i);
mexx[ans]=1;
}
for(int i=0;;i++){
if(!mexx[i])
return re[p]=i;
}
}
int main()
{
int tcase,i,n;
scanf("%d",&tcase);
while(tcase--){
scanf("%d",&n);
mem(re,-1);
for(i=0;i<n;i++){
scanf("%d",&pri[i]);
mex(pri[i]);
}
for(i=1;i<100;i++)
printf(" %d ",re[i]);
}
return 0;
}*/
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define M 1000600
#define N 10006
int main()
{
int tcase,i,n,ans,pri;
scanf("%d",&tcase);
while(tcase--){
scanf("%d",&n);
ans=0;
for(i=0;i<n;i++){
scanf("%d",&pri);
int temp=pri%4;
if(temp==0)ans^=pri-1;
else if(temp==3)ans^=pri+1;
else ans^=pri;
}
if(ans)printf("Alice\n");
else printf("Bob\n");
}
return 0;
}