Knights in Chessboard

Knights in Chessboard Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

Given an m x n chessboard where you want to place chess knights. You have to find the number of maximum knights that can be placed in the chessboard such that no two knights attack each other.

Those who are not familiar with chess knights, note that a chess knight can attack 8 positions in the board as shown in the picture below.

Input

Input starts with an integer T (≤ 41000), denoting the number of test cases.

Each case contains two integers m, n (1 ≤ m, n ≤ 200). Here m and n corresponds to the number of rows and the number of columns of the board respectively.

Output

For each case, print the case number and maximum number of knights that can be placed in the board considering the above restrictions.

Sample Input

3

8 8

3 7

4 10

Sample Output

Case 1: 32

Case 2: 11

Case 3: 20

 

 

/*
此题目用DFS会超时,因为数据达到了200组以上,
所以只能找规律,
对于只有1*1的情况就是1
对于2*2的情况的则是4
如此我们可以发现规律,对于只有两行的数据他的最佳解与另一条边的长度有关
当不是二的倍数的时候是n+1,是二的倍数但不是4的倍数则是n+2;是二的倍数又是四的倍数则为n;
对于大于三行的数据,玩过国际象棋的人都知道,位于白色部分他所放的棋子最多,就是(n*m+1)/2
*/
/****************************************/
/*最加解释:
对于只有两行的是先填个田字然后再填个田字
*/
/****************************************/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int t,n,m;
int main() {
    int cas=0;
    scanf("%d",&t);
    while(t--) {
        scanf("%d%d",&m,&n);
        int ans=0;
        if(n==1||m==1) ans=m*n;
        else if(n==2||m==2) {
            if(n==2) swap(n,m);
            if(n%2==0&&n%4==0) ans=n;
            else if(n%2==0&&n%4!=0) ans=n+2;
            else ans=n+1;
        } else ans=(n*m+1)/2;
        printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}


你可能感兴趣的:(DFS)