HDU 2844 coin 【多重背包】--暂时还不会全部,待补

Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output

For each test case output the answer on a single line.
 

Sample Input

     
     
     
     
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output

     
     
     
     
8 4



板子题,但是题意不理解;

1:DP[i]=i 代表什么;

2.下标为1是因为代表可能性,如果0那是永远都有的可能


套板子直接写:

#include <bits/stdc++.h>
using namespace std ;
const int N = 100000;
int n , m ;
int dp[N],w[N],c[N];
//*完全包 
void compeletepack(int cost , int weight)
{
	for(int i = cost ; i<=m;i++)
	{
		dp[i]=max(dp[i],dp[i-cost]+weight);
	}
}
//*01
void zeropack(int cost ,int weight)
{
	for(int i = m ; i>=cost;i--)
	{
		dp[i]=max(dp[i],dp[i-cost]+weight);
	}
}
//*多重
void muipack(int cost , int weight , int number)
{
	if(cost*number>=m)
	{
		compeletepack(cost,weight);
	}
	else 
	{
		int k = 1 ;
		while(k<=number)
		{
			zeropack(k*cost,k*weight);
			number-=k;
			k*=2;
		}
	}
	zeropack(number*cost,weight*number);
 } 
int main()
{
	while(scanf("%d%d",&n,&m),n+m)
	{
		for(int i =0;i<n;i++)
		{
			scanf("%d",&c[i]);
		}
		for(int i =0;i<n;i++)
		{
			scanf("%d",&w[i]);
		}
		memset(dp,0,sizeof(dp));
		for(int i = 0 ; i <n ;i++)
		{
			muipack(c[i],c[i],w[i]);
		}
		int sum = 0 ;
		for(int i = 1 ; i <=m;i++)
		{
			if(dp[i]==i)
			{
				sum++;
			}
		}
		 printf("%d\n",sum);
	}
	return 0 ;
} 



你可能感兴趣的:(HDU 2844 coin 【多重背包】--暂时还不会全部,待补)