hdoj 4405 Aeroplane chess(概率dp)

Aeroplane chess



Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
   
   
   
   
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
   
   
   
   
1.1667 2.3441
 

Source
2012 ACM/ICPC Asia Regional Jinhua Online

求期望
fly[x]=y 记录有一条从x通往y的捷径 
初始fly[x]=0
从后往前推 dp[n]记录n点到终点的期望步数
dp公式
fly[x]!=0 dp[x]=dp[fly[x]]即x点的期望步数就是x点飞往的那个点的期望步数
fly[x]=0 dp[x]=(dp[x+1]+......+dp[x+6])/6+1 要么x点的期望步数就是后面六个点的平均步数+1(期望公式)
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 100005;
int fly[N];
double dp[N];
int main()
{
    int n,m,i,x,y,j;
    while(scanf("%d%d",&n,&m)&&n+m )
    {
        memset(fly,0,sizeof(fly));
        memset(dp,0,sizeof(dp));
        while(m--)
        {
            scanf("%d%d",&x,&y);
            fly[x]=y;
        }
        dp[n]=0;
        for(i=n-1;i>=0;i--)
        {
            if(fly[i])
                dp[i]=dp[fly[i]];
            else
            {
                for(j=1;j<=6;j++)
                    dp[i]+=((1.0/6.0)*dp[i+j]);
                dp[ i ]+=1.0;
            }
        }
        printf("%.4lf\n",dp[0]);
    }
    return 0;
}

 

你可能感兴趣的:(hdoj 4405 Aeroplane chess(概率dp))