POJ 2054 && HDOJ 1055

Color a Tree
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 6573   Accepted: 2217

Description

Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes. 

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try. 

Each node has a "coloring cost factor", Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi. 

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33. 
POJ 2054 && HDOJ 1055_第1张图片
Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.

Input

The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed. 

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed. 

Output

For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.

Sample Input

5 1
1 2 1 2 4
1 2
1 3
2 4
3 5
0 0

Sample Output

33

Source

Beijing 2004
一道极好的贪心,我也是看了大神的思路才懂的。
请看 http://www.cnblogs.com/yu-chao/archive/2012/02/19/2358565.html
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>


using namespace std;
//#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1|1
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
#define mid ((l + r) >> 1)
#define mk make_pair
const int MAXN = 1000 + 100;
const int maxw = 10000000 + 20;
const int MAXNNODE = 10000 +10;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
#define mod 10007
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pii;
struct node
{
    int i , next , cost;
}verx[MAXN];
int head[MAXN] , N , num[MAXN] , fact[MAXN], father[MAXN] , vis[MAXN];
int add (int s  , int w)
{
    verx[N].i = w;
    verx[N].cost = 0;
    verx[N].next = head[s];
    return N++;
}
int find(int n  , int root)
{
    int  k;
    D max = 0;
    FORR(i , 1 , n)
    {
        if(!vis[i]&&i != root&&max < (D)fact[i] / num[i])
        {
            max = (D)fact[i] / num[i];
            k = i;
        }
    }
    return k;
}
void Union(int k , int pre)
{
    fact[pre] += fact[k];
    num[pre] += num[k];
    for(int j  = head[k] ; j ; j = verx[j].next)
    {
        father[verx[j].i] = pre;
    }
}
int work(int n , int root)
{
    int k , pre , sum = 0;
    FOR(i , 1 , n)
    {
        k = find(n , root);///查找最大平均值
        vis[k] = 1;
        pre = father[k];
        while(vis[pre])pre = father[pre];///查找father[k]所在的集合
        sum += num[pre] * fact[k];
        Union(k , pre);
    }
    return sum + fact[root];
}
int main()
{
    //ios::sync_with_stdio(false);
#ifdef Online_Judge
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
#endif // Online_Judge
    int m , n , s , w;
    while(scanf("%d%d" , &n , &m)&&(n || m))
    {
        clr(vis , 0);
        N = 1;
        clr(head , 0);
        FORR(i , 1 , n)
        {
            scanf("%d",&fact[i]);
            num[i] = 1;
        }
        FOR(i , 1 , n)
        {
            scanf("%d%d" , &s , &w);
            head[s] = add(s , w);
            father[w] = s;
        }
        printf("%d\n",work(n , m));
    }
    return 0;
}


你可能感兴趣的:(ACM,贪心)