HDU 1789Doing Homework again 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9777    Accepted Submission(s): 5722


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
   
   
   
   
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
   
   
   
   
0 3 5 题意: 求最少扣得分数。。 思路:对扣的分从大到小进行排序,让他们放在期限的最后一天,如果存在就往前放,如果前面不存在可以存放的位置,就累加起来。
#include<bits/stdc++.h>
using namespace std;
struct node
{
    int day,num;
} a[100000];
int vis[1000010];
int cmp(node p1,node p2)
{
    return p1.num>p2.num;
}
int main()
{
    int T,n;
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            memset(vis,0,sizeof(vis));
            int sum=0;
            scanf("%d",&n);
            for(int i=0; i<n; i++)
            {
                scanf("%d",&a[i].day);
            }
            for(int i=0; i<n; i++)
            {
                scanf("%d",&a[i].num);
            }
            sort(a,a+n,cmp);
            for(int i=0; i<n; i++)
            {
                if(vis[a[i].day]==0)
                {
                    vis[a[i].day]=1;
                }
                else
                {
                    int j;
                    for(j=a[i].day-1; j>=1; j--)
                    {
                        if(vis[j]==0)
                        {
                            vis[j]=1;
                            break;
                        }
                    }
                    if(j==0)
                        sum+=a[i].num;
                }
            }
            printf("%d\n",sum);
        }
    }
    return 0;
}


你可能感兴趣的:(HDU 1789Doing Homework again 贪心)