Poj 3624 Charm Bracelet

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14114   Accepted: 6457

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver


01背包


#include<stdio.h>
#include<string.h>

int w[3403],v[3403];
int f[12881];

int main(void)
{
	int N,V;
	while(scanf("%d%d",&N,&V)==2)
	{
		int i,j;
		for(i=1;i<=N;i++)
			scanf("%d%d",&w[i],&v[i]);
		memset(f,0,(V+1)*sizeof(int));
		for(i=1;i<=N;i++)
			for(j=V;j>=w[i];j--)
				f[j]=f[j]>f[j-w[i]]+v[i]?f[j]:f[j-w[i]]+v[i];
		printf("%d\n",f[V]);
	}
	return 0;
}

你可能感兴趣的:(Poj 3624 Charm Bracelet)