区间dp

http://acm.hdu.edu.cn/showproblem.php?pid=4632

Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <S x1, S x2, ..., S xk> and Y = <S y1, S y2, ..., S yk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if S xi = S yi. Also two subsequences with different length should be considered different.
 

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 

Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 

Sample Input
   
   
   
   
4 a aaaaa goodafternooneveryone welcometoooxxourproblems
 

Sample Output
   
   
   
   
Case 1: 1 Case 2: 31 Case 3: 421 Case 4: 960
令dp[i][j] 表示[i,j]区间内含有的回文子序列,dp[i][j]=d[i+1][j]+dp[i][j-1]-dp[i+1][j-1];如果dp[i][j]在加上dp[i+1][j]+dp[i][j-1]+1;

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int MOD=10007;
char a[1005];
int dp[1005][1005];
int main()
{
    int n,T;
    int tt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",a+1);
        n=strlen(a+1);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            dp[i][i]=1;
        for(int i=n-1;i>0;i--)
        {
            for(int j=i+1;j<=n;j++)
            {
                dp[i][j]=max(dp[i][j],dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1]+MOD)%MOD;
                if(a[i]==a[j])
                    dp[i][j]=(dp[i][j]+1+dp[i+1][j-1])%MOD;
            }
        }
        printf("Case %d: %d\n",tt++,dp[1][n]);
    }
    return 0;
}


你可能感兴趣的:(区间dp)