练习三1015

Problem O

Time Limit : 1000/1000ms (Java/Other)   Memory Limit :32768/32768K (Java/Other)


Problem Description

Give you a numberon base ten,you should output it on base two.(0 < n < 1000)

 

 

Input

For each casethere is a postive number n on base ten, end of file.

 

 

Output

For each caseoutput a number on base two.

 

 

Sample Input

1

2

3

 

 

Sample Output

1

10

11

 


题意:

十进制转二进制。



解题思路:

一个十进制转化成二进制,还弄成英文的,这么神秘!!



#include<stdio.h>
int main()
{
int n,i,j,a[100];
while(scanf("%d",&n)!=EOF)
{
i=0;
while(n)
{ 
a[i]=n%2;
n=n/2;
i++;
}
for(j=i-1;j>=0;j--)
printf("%d",a[j]);
printf("\n");
}
return 0;
} 


 

你可能感兴趣的:(练习三1015)