A Walk Through the Forest 最短路+记忆化搜索DFS


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
   
   
   
   
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
   
   
   
   
2 4
 
题意是这样的存在一条路从A到B,且将选择这条路回家,现在是问从B到家短于任意一条从A到家的路,问存在这样的从A到家的路有多少条
 
本题需最短路和记忆化搜索结合,用DFS会是超时,用BFS会超内存
 
参考代码:
#include<iostream>
using namespace std;
const int INF=100000000;
const int MAXN=1005;
int n,m;
int S[MAXN],dist[MAXN],map[MAXN][MAXN];//分别为熟悉的变量
int sum[MAXN];//记录存在多少条这样的路
void Dijkstra(int v)//核心算法
{
	int i,j,k,u;
	for(i=1;i<=n;i++)
	{
		dist[i]=map[v][i];
		S[i]=0;
	}
	S[v]=1;
	dist[v]=0;
	for(i=0;i<n-1;i++)
	{
		int min=INF,u=v;
		for(j=1;j<=n;j++)
		{
			if(!S[j]&&dist[j]<min)
			{
				u=j;
				min=dist[j];
			}
		}
		
		S[u]=1;
		for(k=1;k<=n;k++)
		{
			if(!S[k]&&map[u][k]<INF&&dist[k]>dist[u]+map[u][k])
			{
				dist[k]=dist[u]+map[u][k];
			}
		}
	}
}
DFS(int i)//记忆化搜索的开始
{
	int j;
	if(i==2)
		return 1;
	if(sum[i]!=-1)
		return sum[i];
	int cnt=0;
	for(j=1;j<=n;j++)
	{
		if(map[i][j]<INF&&dist[j]<dist[i])
			cnt+=DFS(j);
	}
	sum[i]=cnt;
	return sum[i];
}
int main()
{
	int i,j;
	while(cin>>n)
	{
		if(n==0)
			break;
		cin>>m;
		for(i=0;i<=n;i++)
		{
			for(j=0;j<=n;j++)
				map[i][j]=i==j?0:INF;
		}
		int a,b,w;
		while(m--)
		{
			cin>>a>>b>>w;
			if(map[a][b]<w)
				continue;
			map[a][b]=w;
			map[b][a]=w;
		}
		Dijkstra(2);//从终点倒退最短路  最起码的底线
		memset(sum,-1,sizeof(sum));
		cout<<DFS(1)<<endl;//从起点搜索
	}
	return 0;
}

 

你可能感兴趣的:(Integer,Office,Path,each,output,distance)