HDU 2602 Bone Collector (01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 45368    Accepted Submission(s): 18878


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU 2602 Bone Collector (01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
 
刚刚学到DP  练练简单题:
题目就是和01背包完全一样  只不过物品改为了骨头!骨头有体积和价值!

有个坑就是可能有骨头体积为0,但依然有价值!!

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1000 + 10;
int dp[maxn][maxn],w[maxn],v[maxn],N,V;
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&N,&V);
		for (int i = 0; i < N; ++i)scanf("%d",&w[i]);
		for (int i = 0; i < N; ++i)scanf("%d",&v[i]);
		memset(dp,0,sizeof(dp));
		for (int i = 1; i <= N; ++i){	
			for (int j = 0; j <= V; ++j){
				if (j < v[i-1])dp[i][j] = dp[i-1][j];
				else dp[i][j] = max(dp[i-1][j],dp[i-1][j-v[i-1]]+w[i-1]);
			}
		}
		printf("%d\n",dp[N][V]);
	}
	return 0;
}


你可能感兴趣的:(动态规划,C语言)