HDU3172 Virtual Friends 并查集

 

Problem Description

 

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.  

Your task is to observe the interactions on such a website and keep track of the size of each person's network.  

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 


 

Input

 

Input file contains multiple test cases.  
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 


 

Output

 

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 


 

Sample Input

 

   
   
   
   
1 3 Fred Barney Barney Betty Betty Wilma
 


 

Sample Output

 

   
   
   
   
2 3 4
 


   题意是这样的:给你两个人,他们是朋友关系,判断在他们朋友关系的集合中有几对这样的关系,比如说小明和小红是朋友,小红和小李是朋友,那么小明和小李也是朋友;题意很明白就是并查集的简单应用,关键是名字如何用数字来一一表示。这里用map来实现,还有很多实现方法,我愿闻其详。

代码:

#include<iostream>
#include<string>
using namespace std;
#define MAX 100005
int parent[MAX],deep[MAX];
#include<map>
int Max;
map <string,int> A;
int Find(int x)
{
	int s=x;
	int temp;
	while(s!=parent[s])
	{
		s=parent[s];
	}
	while(s!=x)
	{
		temp=parent[x];
		parent[x]=s;
		x=temp;
	}
	return s;
}
void Union(int x,int y)
{
	int a=Find(x);
	int b=Find(y);
	if(a==b)
		return;
	if(a!=b)
	{
		parent[a]=b;
		deep[b]+=deep[a];
	}
}
int main()
{
	int T,n;string name1,name2;
	
	while(scanf("%d",&T)!=EOF)
	{
		while(T--)
		{
			scanf("%d",&n);
			Max=0;
			A.clear();
			while(n--)
			{
				cin>>name1>>name2;
				if(A.find(name1)==A.end())
				{
					Max++;
					A[name1]=Max;
					parent[Max]=Max;
					deep[Max]=1;
					
				}
				if(A.find(name2)==A.end())
				{
					Max++;
					A[name2]=Max;
					parent[Max]=Max;
					deep[Max]=1;
				}
				Union(A[name1],A[name2]);
				int p=Find(A[name2]);
				printf("%d\n",deep[p]);
			}    
		}
	}
	
	return 0;
}


求效率更好的实现方法。

你可能感兴趣的:(String,Integer,NetWork,each,Social,website)